Error while executing the graph on the Server

Support/help with CloverETL implementation problems

girish_526
Posts: 16
Joined: Wed Jan 04, 2017 7:14 am

Error while executing the graph on the Server

Postby girish_526 » Thu Dec 21, 2017 10:37 am

Hi Everyone,

We are facing the below error while executing the graph.

Thanks in advance.

Error during graph initialization !
Graph configuration is invalid.
Issue in component [Create:CREATE]
org.jetel.component.RecordFilterFactory.createFilter(Ljava/lang/String;Lorg/jetel/metadata/DataRecordMetadata;Lorg/jetel/graph/TransformationGraph;Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;Lorg/apache/commons/logging/Log;)Lorg/jetel/component/RecordFilter;

vazquezrosariop
Posts: 131
Joined: Mon Feb 29, 2016 5:33 pm

Re: Error while executing the graph on the Server

Postby vazquezrosariop » Thu Dec 21, 2017 5:24 pm

Hi girish_526

Based on the stack trace it's a bit difficult to pinpoint whats causing the issue, thus could you please answer the following questions:

    1. CloverETL version, Application Server vendor, version, Java version
    2. Component original name, e.g. FlatFileWriter
    3. all.log file located in [TOMCAT_HOME]/temp/cloverlogs

Thanks
---
Pedro Vazquez Rosario
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at http://www.cloveretl.com
How to speed up communication with CloverCARE support

girish_526
Posts: 16
Joined: Wed Jan 04, 2017 7:14 am

Re: Error while executing the graph on the Server

Postby girish_526 » Sat Jan 06, 2018 4:59 pm

Please find the details:

1. CloverETL version, Application Server vendor, version, Java version
Clover Versoin : 4.3.0
Application Server is Glass Fish version 3.1.2
Java Version 1.7

2. Component original name, e.g. FlatFileWriter
It fails in the begining without loading any component saying Graph configuration is Invalid.

3. all.log file located in [TOMCAT_HOME]/temp/cloverlogs
Attachments
ETL_ERROR_LOG.log
(128.23 KiB) Downloaded 22 times

girish_526
Posts: 16
Joined: Wed Jan 04, 2017 7:14 am

Re: Error while executing the graph on the Server

Postby girish_526 » Wed Jan 17, 2018 6:09 am

Hi Team,

Can I have an update on this please.

Thanks,
Girish.

vazquezrosariop
Posts: 131
Joined: Mon Feb 29, 2016 5:33 pm

Re: Error while executing the graph on the Server

Postby vazquezrosariop » Wed Jan 17, 2018 2:51 pm

Hi Girish,

Sorry for the delay, could you please share your graph. I would like to see how it's configured, based on the information of the all.log it's difficult to pinpoint which component is the cause.

Thanks,
---
Pedro Vazquez Rosario
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at http://www.cloveretl.com
How to speed up communication with CloverCARE support