Page 1 of 1

How to turn off direct memory

Posted: Fri Sep 01, 2017 7:37 pm
by ramiro
Hello,

We are using cloverETL 4.2.0.9/9, and we hit the following issue in our production servers:

https://bug.javlin.eu/browse/CLO-5651

We tried to disable Direct Memory, by putting "USE_DIRECT_MEMORY = false" into a new file in tomcat_dir/conf/engine.config

Then adding a line to our clover config:
engine.config.file= tomcat_dir/conf/engine.config

After restarting the server, we see confirmation that direct memory is off in the Configuration / CloverETL info / Engine Properties section (see first attachment)
Screen Shot 2017-09-01 at 11.31.52 AM.png
Screen Shot 2017-09-01 at 11.31.52 AM.png (61.98 KiB) Viewed 107 times


but when we go to the monitoring section, we still see the server using direct memory (see second attachment)
Screen Shot 2017-09-01 at 11.30.57 AM.png
Screen Shot 2017-09-01 at 11.30.57 AM.png (66.44 KiB) Viewed 107 times


Are we missing any steps? or is that second screen shot in the monitoring section showing something unrelated that just happen to be labeled Direct Memory, and direct memory is truly now off?

Please let us know, as we don't know if the setting took place.

Re: How to turn off direct memory

Posted: Mon Sep 04, 2017 1:03 pm
by jandikovae
Hi,

I can confirm that you have done everything correctly. As long as you can see USE_DIRECT_MEMORY set to "false" in the Configuration -> CloverETL Info -> Engine Properties section, the Direct Memory is disabled for CloverETL Server.

The "Direct Memory" attribute in the Monitoring section is an actual consumption of the direct memory in general and it can sometimes show some usage even when it's turned off for the CloverETL Server. It means the direct memory is used by the Tomcat itself or some other application.

Please let me know if you encounter any follow-up question regarding this. Thanks.

Best Regards,
Eva