jzhu
Posts: 19
Joined: Tue Jul 19, 2016 12:34 pm

CloverETL server fails to start after DB configuration change to Oracle 11g/12c

Postby jzhu » Tue Sep 20, 2016 5:02 pm

Initially, the DB configuration (for both Oracle DB 11g/12c) worked after fiddling around with server v.4.2.1 (Tomcat).
I restarted from fresh, in order:
(1) stop and remove 4.2.1,
(2) reinstall 4.3.0,
(3) drop all (39) tables in the DB,
(4) start 4.3.0,
(5) add license
(6) configure DB (Oracle), validate and save
(7) shutdown and start 4.3.0
(8) server web interface shows:
CloverETL Server initialization has failed
Root exception
java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist
Stack trace
javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not extract ResultSet
..

Check the DB, there are only 20 tables (usually 39), including one new table (GRAPH_EVENt_LISTENER) which does not exist among the 39 tables.

Repeat the procedure with 4.2.1 (instead of 4.3.0 above), and fails in the same way as above.
I cannot remember how I got the DB working in the first place -- it was not straight forward.

Any idea what caused the problem?

Thanks

vazquezrosariop
Posts: 96
Joined: Mon Feb 29, 2016 5:33 pm

Re: CloverETL server fails to start after DB configuration change to Oracle 11g/12c

Postby vazquezrosariop » Wed Sep 21, 2016 2:57 pm

Hi jzhu,

Just a overview of how you resolved this issue, there was an object(sequence) left in the database after all tables were dropped causing the problem. The issue was solved by dropping the sequence from the database.
---
Pedro Vazquez Rosario
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at http://www.cloveretl.com
How to speed up communication with CloverCARE support


cron