Advices & Best Pratices for Integrator

Discussion on developing CloverETL engine, transformation components etc.

aiaimanel
Posts: 3
Joined: Fri Jun 20, 2014 10:04 am

Advices & Best Pratices for Integrator

Postby aiaimanel » Fri Jun 20, 2014 10:05 am

Hello everyone,

Since I'm new to Endeca, i would like to ask some questions / advices for the experts that come to the forum.
I'm using version 3.1.

I have created a Graph where i add my columns (whenever i need to) and it is programmed to query the DB, do the transformations / joins necessary and pass it to a Bulk Add/Replace Records Component that inserts in the data domain (data store).

My questions are:

1- If i add a new column and i already have the data uploaded in the DD/DS, should i use the same graph with the new column in the metadata or should i create a new graph only containing the new column and use the Bulk Add/Replace Records (or other component) ? Which is the best and more pratical way to do this ? My graph is taking 1 hour (give or take) to update 3.5 M records, when i run it (and it raises linerly when i insert a new column)

2- Since my graph is taking a while to do the replaces, what can i do to improve the performance of such graph ?

Any idea of a component to use or advices regarding this subject ?

Regards and thanks for all the help!

kubosj
Posts: 372
Joined: Thu Jan 12, 2012 9:10 am

Re: Advices & Best Pratices for Integrator

Postby kubosj » Fri Jun 20, 2014 10:16 am

Dear aiaimanel,

As this issue relates to Endeca Data Integrator please do contact Oracle Endeca support in this matter directly. They need to be informed about this issue and will work with us directly if needed. Thank you for your cooperation!
Jaroslav Kubos
CloverCARE Support
CloverETL | Rapid Data Integration

Visit us online at http://www.cloveretl.com

aiaimanel
Posts: 3
Joined: Fri Jun 20, 2014 10:04 am

Re: Advices & Best Pratices for Integrator

Postby aiaimanel » Fri Jun 20, 2014 12:16 pm

Hey Kubosj,

First of all, thanks very much for the fast reply.

I think i misunderstood the forum perhaps. I created this topic since it was a Endeca forum and maybe someone could help me out.
It is not a support kind of problem. It is a simple performance / not knowing sufficient about Endeca problem.

It was for the sake of learning and understanding Endeca better.

Thanks very much for the reply. I am going to try to discover more about my problem! :)

Regards and have a good weekend!