Search found 9 matches

by listsos
Fri Jan 19, 2018 2:38 pm
Forum: IBM InfoSphere MDM
Topic: Error: AggregationException: Invalid mapping
Replies: 6
Views: 78

Re: Error: AggregationException: Invalid mapping

Thanks for your assistance Vladimir!
by listsos
Wed Jan 17, 2018 3:16 pm
Forum: IBM InfoSphere MDM
Topic: Error: AggregationException: Invalid mapping
Replies: 6
Views: 78

Re: Error: AggregationException: Invalid mapping

Thanks for the reply! I am using the CloverETL Designer bundled in with IBM MDM Workbench 10.1. The CloverETL Designer version is 2.9.7. Under the aggregation function, contants and fields, when using the GUI to map the input field to the output field I am getting an error: Invalid mapping '$LASTACT...
by listsos
Thu Jan 11, 2018 3:05 pm
Forum: IBM InfoSphere MDM
Topic: Escape Pipe Characters In Extract
Replies: 3
Views: 627

Re: Escape Pipe Characters In Extract

Issue resolved. Thanks!
by listsos
Thu Jan 11, 2018 1:30 pm
Forum: IBM InfoSphere MDM
Topic: Error: AggregationException: Invalid mapping
Replies: 6
Views: 78

Re: Error: AggregationException: Invalid mapping

To follow up: It appears the mapping doesn't just fail for EID, failing for all values under mapping. If I remove the EID mapping from the aggregate, the next entry fails with the same error. I am verifying the mapping in the below portion of the gtf file: <Node aggregateKey="ECID" enabled...
by listsos
Wed Jan 10, 2018 8:17 pm
Forum: IBM InfoSphere MDM
Topic: Error: AggregationException: Invalid mapping
Replies: 6
Views: 78

Error: AggregationException: Invalid mapping

Hello! Running the graph via Workbench CoverETL runs successfully, however the graph errors out when running from the command line (using *.grf) during the aggregate: ERROR [main] - [AGGREGATE0] - org.jetel.component.aggregate.AggregationException: Invalid mapping '$EID:=firstnonnull($EID)' : The EI...
by listsos
Fri Dec 08, 2017 2:40 pm
Forum: IBM InfoSphere MDM
Topic: Write SUCCESS flag to Database After Successful DB Output
Replies: 4
Views: 120

Re: Write SUCCESS flag to Database After Successful DB Output

Also note that the first DB Output Table job (after the MEMGET) will add thousands of records. I simply want to add a single SUCCESS or FAILURE flag to another database table when the graph completes.
by listsos
Thu Dec 07, 2017 8:12 pm
Forum: IBM InfoSphere MDM
Topic: Write SUCCESS flag to Database After Successful DB Output
Replies: 4
Views: 120

Re: Write SUCCESS flag to Database After Successful DB Output

Thanks for your reply! I have moved the SUCCESS job the Port 1. I don't have any metadata selected for the connection as the SUCCESS job will simply be running "UPDATE STATUS_TABLE set STATUS = 'SUCCESS" presuming the graph completes successfully. When running the job, it now errors statin...
by listsos
Wed Dec 06, 2017 8:16 pm
Forum: IBM InfoSphere MDM
Topic: Write SUCCESS flag to Database After Successful DB Output
Replies: 4
Views: 120

Write SUCCESS flag to Database After Successful DB Output

I have a reporting database that is updated using the DB_OUTPUT_TABLE, using an 'Insert Into'. Records are retrieved using a MEMGET and inserted into the table using the above writer. After the above DB_OUTPUT_TABLE writer job is finished, I would like to update another table with either a 'SUCCESS'...
by listsos
Fri Aug 18, 2017 5:59 pm
Forum: IBM InfoSphere MDM
Topic: Escape Pipe Characters In Extract
Replies: 3
Views: 627

Escape Pipe Characters In Extract

In CloverETL, I am creating an extract of our registry. The extract will be pipe | delimited. The problem is that some of our attributes contain the pipe value, for example a first name is John| I am attempting to escape these characters using a transformer but not having much luck. Currently my Gra...